Cerca nel blog

Come configurare VPN ikev2 su mikrotik con Surfshark

In questa guida vi mostro come configurare una VPN surfshark su mikrotik, tramite il protocollo ikev2. Grazie a questa guida riuscirete ad utilizzare la vpn senza piu problemi di disconessione ogni 10 secondi della vpn, che causava appunto problemi con la guida presente nel sito ufficiale surfshark.

Cos'è una vpn?

Una Virtual Private Network (abbreviato VPN) è un tunnel criptato, che consente ad un utente connesso di mantere un anonimato online, garantendo una privacy durante l'utilizzo della navigazione. La vpn è molto utile se si utilizza una rete wifi pubblica, dove potrebbero esserci dei malintezionati che potrebbero sferrare attacchi contro tale rete presente ed magari eseguire attività maligne.

Cos'è ikve2?

L'Internet Key Exchange Version 2 è un protocollo criptato utilizzato dalle VPN in grado di dare protezione al traffico internet in esecuzione sul dispositivo che si utilizza.

Installazione:

Prima di eseguire tale procedura abbiamo bisogno di una versione specifica del firmware Mikrotik ovvero la versione 6.47.2. In quanto grazie a questa versione riusciamo a correggere un problema di interruzzione della vpn dopo circa 5-10 secondi

Procediamo ora, apriamo winbox inseriamo le nostre credenziali, poi andiamo sul sito surfshark inseriamo anche li le credenziali, e scarichiamo la configurazione ikev2 come nell'immagine qui sotto.


Ora torniamo su winbox, rechiamoci in Files poi clicchiamo su Upload e carichiamo il certificato scaricato in precedenza. 


Rechiamoci ora su System poi su Certificates clicchiamo su Import e importiamo il certificato appena caricato e diamogli un nome che vogliamo. 


Apriamo ora il terminale e digitiamo i seguenti comandi nel terminale: (per ogni comando premiamo invio).

/ip ipsec profile add name=SURFSHARK 

/ip ipsec proposal add name=SURFSHARK pfs-group=none

/ip ipsec policy group add name=SURFSHARK

/ip ipsec policy add dst-address=0.0.0.0/0 group=SURFSHARK proposal=SURFSHARK src-address=0.0.0.0/0 template=yes

/ip ipsec mode-config add connection-mark=VPN name=SURFSHARK responder=no

In questo comando ora scegliamo il server che vogliamo utilizzare nel mio caso utilizzo un server italiano di milano.

/ip ipsec peer add address=it-mil.prod.surfshark.com exchange-mode=ike2 name=SURFSHARK profile=SURFSHARK

Rechiamoci ora su IP ---> IP SEC andiamo su Identities clicchiamo sul simbolo del + ed inseriamo i seguenti valori:

Perr: SURFSHARK
Auth. Method: eap
EAP Methods: MS-CHAPv2
Certificate: Inserire il certificato ikev2 caricato in precedenza
Remote Certificate: none
Username: in username inserite le credenziali presenti nel vostro login sursfhark
Password: in password inserite le credenziali presenti nel vostro login surfshark
Policy Template Group: SURFSHARK
Notrack Chain: -
My ID Type: auto
Remote ID Type: auto
Match By: remote id
Mode Configuration: SURFSHARK
Generate Policy: port strict

Clicca su Applica e poi clicca OK.


Recatevi in IP ---> DNS ed inserite i DNS manualmente di SURSHARK.
Ora in Firewall inserite questo comando con l'ip gateway corrispondente alla vostra classe IP. Successivamente inserite gli altri comandi di seguito:

/ip firewall address-list add address=192.168.88.0/24 list=local

/ip ipsec mode-config set [ find name=SURFSHARK ] src-address-list=local

Ora la configurazione è terminata, adesso se vi recate su IP---> IPSEC poi su Active Peers vedrete ora che la vpn si continua a disconettere, recatevi ora su IP ----> IPSEC poi cliccate su MOD-CONFIG cliccate due volte sulle configurazioni surfshark importate, e su SRC. ADDRESS.LIST cancellate la scritta local poi premete su applica e ok. Adesso aggiornate la versione 6.47.2 all'ultima versione del firmware mikrotik quindi cliccate su Quick Set poi su Check for Updates. Terminato l'aggiornamento all'ultima versione entrate di nuovo in WinBox recatevi sul terminale e scrivete i seguenti comandi:

/ip firewall mangle add action=mark-connection chain=prerouting new-connection-mark=VPN passthrough=yes

correggiamo ora l' MSS per i pacchetti in avanti:

/ip firewall mangle add action=mark-connection chain=prerouting new-connection-mark=VPN passthrough=yes

ORA POTETE NOTARE CHE LA VPN IN FUNZIONE CORRETTAMENTE BASTA TORNARE SU IP ---> IPSEC E RECARSI SU ACTIVE PEERS IN UPTIME NOTATE IL TEMPO CHE É IN UTILIZZO LA VPN. SPERO CHE QUESTA GUIDA FUNZIONI ANCHE PER VOI, IL MIO TEST LO ESEGUITO SU UN ROUTER MIKROTIK SXT LTE6 KIT. 

Come creare documento PDF compilabile con Adobe Acrobat

In questa guida vi mostro, come creare un documento PDF compilabile con il classico software Adobe Acrobat. Questo software è in grado di leggere e modificare i nostri PDF e convertirli in altri formati compatibili con Microsoft Office. Questa procedura che vi mostro, è una buona alternativa sopratutto per chi lavora con i programmi di scuola o ufficio, infatti grazie a questo metodo che vediamo, possiamo creare i nostri PDF compilabili in modo da dover semplificare ad un alunno oppure ad un cliente di un azienda i PDF senza doverli modificare, ma basterà semplicemente cliccare sopra al riquadro indicato per poter scrivere e salvare succesivamente il documento. 

Adobe Acrobat è un software a pagamento, esistono due versioni in commercio oggi, una chiamta Adobe Acrobat DC disponibile con tre metodi di pagamento:

  1. Pagamento annuale scalabile mensilmente al prezzo di 18,29 euro al mese.
  2. Pagamento annuale prepagato al costo di 18,20 euro.
  3. Pagamento mensile al costo di 30,49 euro al mese.
Oppure è presente una versione Standard DC disponibile sempre con tre metodi di pagamento:

  1. Pagamento annuale scalabile mensilmente al prezzo di 15,85 euro al mese.
  2. Pagamento annuale prepagato al costo di 15,77 euro.
  3. Pagamento mensile al costo di 28,05 euro al mese.
Qui in basso vediamo cosa includono le principali versioni del programma.




Che cos'è un file PDF?

Un file PDF è un documento salvato in formato digitale creato da Adobe in grado di creare e salvare documenti in un formato standard che può essere letto da diverse piattaforme. I file PDF possono essere sia creati da zero è sia convertiti da altri formati comunemente utilizzati.

Procedimento:

Per prima cosa abbiamo bisogno del nostro documento creato in PDF io vi lascio come prova un mio pdf già pronto per eseguire la procedura. Al seguente link. Aprendo il documento notate già dei campi lasciati vuoti, quello che facciamo ora è di creare un modulo automatico di compilazione. Aprite il documento PDF, una volta aperto cliccate su Vista--->Strumenti--->Prepara Modulo---->Apri. Ora ci chiede di cliccare su Avvia per selezionare già il documento aperto, oppure se vogliamo possiamo scegliere altri documenti. In questo caso scegliamo Avvia. Ci troveremo di fronte alla selezione automatica delle caselle vuote. Ora possiamo procedere con il salvataggio del documento appena precompilato.





Una volta salvato, e riaperto il documento, selezionando sopra lo spazio vuoto evidenziato vi troverete a dover compilare il modulo senza dover modificare il PDF. Una volta compilato basterà cliccare su Salva per salvare le modifiche. Questo è il risultato una volta salvato:

Spero che questa guida vi sia utile, sopratutto ora che a causa del covid-19 molti studenti o insegnanti sono alle prese con magari quiz o test di verifiche per l'anno scolastico. Anche per alcune aziende magari di marketing che hanno bisogno di inviare documenti già precompilati per aiutare magari persone in difficoltà nel poter magari stampare i moduli. 

Come trovare password del Wi-Fi salvate dal Prompt dei comandi su Windows

In questa guida vi mostro, come trovare le password del Wi-Fi memorizzate su qualsiasi sistema operativo Windows. Prima di iniziare voglio specificare che questo metodo permette attraverso la connessione Wi-Fi del vostro computer di recuperare le password memorizzate dal momento che noi inseriamo la password la prima volta è che gli diamo la connessione automatica impostata. In sostanza il nostro computer dal momento che digitiamo la password del Wi-Fi e gli diciamo di connettersi in automatico ad ogni accensione, facciamo in modo che il computer salva in una parte delle impostazioni anche la password inserita al primo avvio. Grazie a questo metodo vedremo come recuperare dal famoso terminale Windows(CMD) le password del Wi-Fi salvate sul computer.

Cos'è il Prompt dei comandi?

Il prompt dei comandi o meglio chiamato appunto abbreviato cmd è il classico terminale Windows a riga di comando che è da sempre presente in Windows.

Procediamo ora con il metodo:

Premiamo i tasti Windows + R si aprirà una finestra in basso a sinistra, scriviamo all'interno della barra bianca, cmd. Successivamente scriviamo netsh e premiamo invio.


Dopo scriviamo nella riga sotto wlan


nel terminale ora scriviamo show profiles ora davanti al nostro terminale vediamo tutte le reti wireless salvate nel nostro computer.


ora non resta che selezionare la rete a cui vogliamo recuperare la password salvata quindi scriviamo nel terminale: show profiles nome rete wifi nel mio caso show profiles TV-SAMSUNG key=clear


come notiamo nelle impostazioni di sicurezza del Wi-Fi di fianco alla scritta contenuto chiave noteremo la nostra password impostata alla prima connessione eseguita. 






Configurare internet con Rabona Mobile su Android

In questa mini-guida voglio mostrarvi come configurare internet con Rabona Mobile su Android. La compagnia Rabona Mobile è un operatore Full MVNO (Operatori Virtuali di Rete) che si appoggia alla copertura di Vodafone Italia. Grazie al servizio di copertura offerto da Vodafone Italia permette di raggiungere una copertura superiore al 92,2% della rete mobilePermette di navigare in 4G ad una velocità massima di 60Mbps.


Procediamo con la configurazione, entriamo in Impostazioni, successivamente nel campo di ricerca delle impostazioni, scriviamo Nomi Punti di accesso.


Clicchiamo su Nuovo APN

Nome: RABONA WEB
APN: rabona.it 
Tipo APN: default,supl,dun

Premete ora su Salva per salvare la configurazione, successivamente selezionate l'apn Rabona Mobile cliccandoci sopra con un clic. Ora attivate il roaming Dati e disattivate i dati mobili, riabilitateli è subito dopo noterete internet funzionante con il segno del 4G. Le altre impostazioni che vedete impostate nei miei screenshot non copiateli tranne quelli evidenziati in rosso, gli altri parametri lasciateli così come sono già impostati nel cellulare in vostro possesso.

Configurare internet con Rabona Mobile su iPhone

In questa mini-guida voglio mostrarvi come configurare internet con Rabona Mobile su iPhone. La compagnia Rabona Mobile è un operatore Full MVNO (Operatori Virtuali di Rete) che si appoggia alla copertura di Vodafone Italia. . Grazie al servizio di copertura offerto da Vodafone permette di raggiungere una copertura superiore al 92,2% della rete mobile.  Permette di navigare in 4G ad una velocità massima di 60Mbps.

Per la prima configurazione bisogna recarsi in Impostazioni del proprio iPhone


Poi cliccare su Cellulare


Successivamente cliccare su Rete dati cellulare


Scrivere nel campo APN: rabona.it


Hotspot Personale:
rabona.it

Ora attivate il roaming Dati e disattivate i dati mobili, riabilitateli è subito dopo noterete internet funzionante con il segno del 4G



Configurare internet con Lycamobile su Android

In questa mini-guida voglio mostrarvi come configurare internet con Lycamobile su Android. La compagnia Lycamobile è un operatore Full MVNO (Operatori Virtuali di Rete) che si appoggia alla copertura di Vodafone Italia. Grazie al servizio di copertura offerto da Vodafone Italia permette di raggiungere una copertura superiore al 92,2% della rete mobileDigi Mobil è un operatore uscito in Italia nel 2013 permette di navigare in 4G ad una velocità massima di 60Mbps.


Procediamo con la configurazione, entriamo in Impostazioni, successivamente nel campo di ricerca delle impostazioni, scriviamo Nomi Punti di accesso.


Clicchiamo su Nuovo APN


Ora impostiamo solamente i seguenti valori che scrivo io:

Nome: LycaMobile
APN: data.lycamobile.it
Nome utente: imit 
Password: plus
Tipo APN: default
Protocollo APN: ipv4 



Premete ora su Salva per salvare la configurazione, successivamente selezionate l'apn LycaMobile cliccandoci sopra con un clic. Ora attivate il roaming Dati e disattivate i dati mobili, riabilitateli è subito dopo noterete internet funzionante con il segno del 4G. Le altre impostazioni che vedete impostate nei miei screenshot non copiateli tranne quelli evidenziati in rosso, gli altri parametri lasciateli così come sono già impostati nel cellulare in vostro possesso. Nel caso internet non dovrebbe funzionare vi consiglio di chiamare l'operatore Lycamobile è farsi dire i parametri adatti per il vostro smartphone. Per tutte le altre informazioni vi consiglio di visitare il sito di lycamobile.

Configurare internet con Lycamobile su iPhone

In questa mini-guida voglio mostrarvi come configurare internet con Lycamobile su iPhone. La compagnia Lycamobile è un operatore Full MVNO (Operatori Virtuali di Rete) che si appoggia alla copertura di Vodafone Italia. . Grazie al servizio di copertura offerto da Vodafone permette di raggiungere una copertura superiore al 92,2% della rete mobile. Lycamobile è un operatore uscito in Italia nel 2013 e permette di navigare in 4G ad una velocità massima di 60Mbps.


Per la prima configurazione bisogna recarsi in Impostazioni del proprio iPhone



Poi cliccare su Cellulare


Successivamente cliccare su Rete dati cellulare

Scrivere nel campo APN: data.lycamobile.it

Nome utente: imit (tutto minuscolo)

Password: plus (tutto minuscolo) come in figura:


Hotspot Personale:

data.lycamobile.it

In caso configurando in questa maniera non funziona, provate a compilare solo il campo APN come in tutti gli altri casi, senza scrivere nome utente e password.

Post piu Popolari